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1 Introduction
The Cloud Security Connector (CSC) GRE allows to connect securely to Zscaler Cloud Security 
Services up to 1 Gbps without hassle. 

The main purpose of the CSC GRE family is simplicity: You don’t need to re-architect your 
network. The CSC GRE is a direct replacement of your current Web Security Appliance. You can 
place the CSC GRE on the same network segment that you current appliance and the CSC will 
redirect the traffic to Zscaler. 

No configuration is required. Simply filling a form with your IP addressing, download the CSC 
(VM) and power it on. 

The CSC GRE comes with all parameters to work with Zscaler. As soon you lunch the CSC at the 
location, the CSC will automatically connect to the best Zscaler nodes. The CSC GRE contains the 
perfect configuration for GRE tunnels, firewall rules and routing tables that are necessary. 

You can run the CSC GRE on any virtual software: Vmware, Hyper-V, KVM, etc; and a hardware 
version is also available on request.

All Zscaler functionalities are available. Internal IPs are completely visible on the Zscaler GUI. 

Simple to install with full management from Amazon AWS, Rundeck or SSH.  

2 Key benefits of the Cloud Security Connector GRE
• No Networking knowledge required. No configuration.

• Direct replacement of your current appliance Web Security Appliance.

• Enables any Location to be connected to Zscaler Cloud Security Services up to 1 Gbps.

• Full tunnel redundancy.

• VIP proxy to direct the traffic to Zscaler.

• Bypass Proxy to send the traffic direct to Internet. 

• Easy configuration: After you buy the CSC, you will need to fill a form indicating your IPs 
and GWs. After the form is submitted, you will receive the OVA file to install. 

• All parametrization required for Zscaler is already configured with the optimal values.

• All Zscaler functionalities can be used: Firewall and Web Security.

• Full visibility of internal IPs.

• No operational burden for Administrators. 
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• Full hardened device.

• Works behind a NAT

• All virtual platform supported: Vmware, Hyper-V, KVM, etc. Hardware version available if 
required. 

• One click Status and Configuration. This shows 25 values and does 14 checks. 

• Amazon AWS management

• Zscaler API Ready

• MTR (MyTraceRoute) test to the Zscaler nodes and in the reverse path as well.

• Speedtest.net integrated

• Works with No default Route Scenarios.

• Small OVA instance: 2 CPU, 4 GB RAM, 8 GB Disk
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3 Cloud Security Connector GRE: Network Diagrams
Both CSC GRE Single and Cluster has two interfaces: Internal and External. The External interface 
provides complete isolation from Internal. It is required to use different VLANs (or dedicated 
interface) for each one. 

3.1 CSC GRE Single

3.2 CSC GRE Cluster
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4 Creating the CSC GRE
To create the CSC GRE is very easy. Just filling a form with your IP addressing and the GRE 
tunnels IPs.

4.1 Submit a ticket to Zscaler Support for GRE Instructions
➔ From the GUI, Go to: Help > Submit a Ticket

➔ You will be redirected to the Submit Ticket Page:

Here you need to specify your GRE Public IP
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Important: You need to specify the <city>, <state> and <country> where the IP is located. This 
allows Zscaler Support to indicate the best ZEN nodes for your location. 

➔ After the ticket is submitted, you will receive an email with the GRE information, like this 
one:

Please, note that Tunnel Source IP = <GRE Public IP>  and the values remarked in green will be 
requested when filling the “CSC GRE Form”

4.2 Create the Location on Zscaler GUI
On the Zscaler GUI, go to Administration > Location > Add Location

➔ Mandatory: Put Name, Country and Time Zone. Select the Public IP  requested for the 
location. 
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➔ Optional: Select additional options for the Location according your design, like Enforce 
Authentication, SSL inspection, Surrogate IP, etc.  

➔ Click “Save”  

➔ and “Activate”. Click the RED indication on the top right of the screen and activate the 
changes. 
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4.3 Filling the Form
After you buy the CSC, you will receive a Welcome Email with the indication about to fill the a 
form with your data. Here a partial view of the form:

The form is very easy to fill. The values that you need to ingress are:

1. Email

2. Company Name

3. Zscaler Company ID

4. Zscaler Cloud Name

5. Your domain
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6. Location Name

7. Internal Interface: First IP / Bitmask (*) and Gateway.

8. External Interface First IP/Bitmask (**) Gateway.

9. DNS Servers. 

10. Syslog Servers and TCP port

11. Input your GRE tunnel information.

(*) The CSC GRE Single uses 3 x IPs. The CSC GRE Cluster uses 5 x IPs.

(**)  The CSC GRE Single uses 2 x IPs. The CSC GRE Cluster uses 4 x IPs.

4.4 CSC files: OVA, URL/Bypass PAC example.
After filling the form, you will receive an email containing links to download two files:

• cgcxxx-v-y-z.ova (your Open Virtual Appliance file to install in your virtual infrastructure)

• cgcxxxxx-url-bypass-pac.txt (Instructions to create the “Bypass PAC” to feed your CSCs 
Bypass List. It contains your Bypass PAC URL already configured on the CSCs) 
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5 Firewall Requirements 

5.1 CSC GRE Cluster

5.1.1 Mandatory Firewall Rules:

External IP# Source Protocol Ports / Service Destination

First Tunnel IP GRE (47) None.(1) Zscaler Nodes

Second Bypass Proxy Egress IP TCP 80, 443 Internet

1024-65535 (2) Internet

Third  CSC IP(eth0) -a TCP 80, 433 Zscaler Nodes
Zscaler PAC ServersFourth  CSC IP(eth0) -b

5.1.2 Optional Firewall Rules:

5.1.2.1 If using external DNS (on the internet)

External IP# Source Protocol Ports / Service Destination

Third  CSC IP(eth0) -a TCP, UDP 53 Public DNS Servers

Fourth  CSC IP(eth0) -b

5.1.2.2 If using AWS management

External IP# Source Protocol Ports / Service Destination

Third  CSC IP(eth0) -a TCP 443 AWS SSM Agent URLs: (3)
ssm.<AWS region>.amazonaws.com
ec2messages.<AWS region>.amazonaws.comFourth  CSC IP(eth0) -b

5.1.2.3 For MyTraceroute test when tunnels are down.

External IP# Source Protocol Ports / Service Destination

Third  CSC IP(eth0) -a ICMP echo-request Zscaler Nodes
Zscaler PAC filesFourth  CSC IP(eth0) -b

Zscaler Nodes
Zscaler PAC files

ICMP echo-reply
time-exceeded

 CSC IP(eth0) -a 
 CSC IP(eth0) -b

1 GRE is protocol and has not ports (like protocol TCP or UDP)
2 This ports are optional but are required for Web sites that are using this particular ports, for example: 

http://www.example.com:8080
3 The URL of the AWS SSM agent are different depending the AWS region. For example, Ireland is “eu-west1”
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5.2 CSC GRE Single

5.2.1 Mandatory Firewall Rules:

External IP# Source Protocol Ports / Service Destination

First Tunnel IP GRE (47) None.(4) Zscaler Nodes

TCP 80, 443 Zscaler Nodes
Zscaler PAC Servers

Second Bypass Proxy Egress IP TCP 80, 443 Internet

1024-65535 (5) Internet

5.2.2 Optional Firewall Rules:

5.2.2.1 If using external DNS (on the internet)

External IP# Source Protocol Ports / Service Destination

First  Tunnel IP TCP, UDP 53 Public DNS Servers

5.2.2.2 If using AWS management

External IP# Source Protocol Ports / Service Destination

First  Tunnel IP TCP 443 AWS SSM Agent URLs: (6)
ssm.<AWS region>.amazonaws.com
ec2messages.<AWS region>.amazonaws.com

5.2.2.3 For MyTraceroute test when tunnels are down.

External IP# Source Protocol Ports / Service Destination

First  Tunnel IP ICMP echo-request Zscaler Nodes
Zscaler PAC files

Zscaler Nodes
Zscaler PAC files

ICMP echo-reply
time-exceeded

 CSC IP(eth0) -a 
 CSC IP(eth0) -b

4 GRE is protocol and has not ports (like protocol TCP or UDP)
5 This ports are optional but are required for Web sites that are using this particular ports, for example: 

http://www.example.com:8080
6 The URL of the AWS SSM agent are different depending the AWS region. For example, Ireland is “eu-west1”
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6 Installing the OVA file in your Virtual Platform.
The following examples shows the installation on Vmware and Hyper-V. 

6.1 Using VMware 5.x
1. Go to vSphere, File > Deploy OVF template

2. Select the OVA File:

3. OVF Template Details: Click Next

4. Name and Location: Put the Name you want.

5. Resource Pool: Place the VM where you want.

6. Disk Format: Click Next

7. Network Mapping: Please map the interfaces EXTERNAL and INTERNAL to your 
interfaces.  Here an example:

8. Click “Next”

9. Click “Finish”
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6.2 Using VMware 6.x
1. Go to Virtual Machines → Create/Register VM

2. Deploy a virtual machine from an OVF or OVA file

3. Click “Next”

4. Put a “Name” and “Select the OVA File”

5. Click “Next”

6. Select Storage and click Next
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7. On “Deployment options”, Select:

a) “Network Mappings” → Select “EXTERNAL” and “INTERNAL” interfaces of the 
CSC.

b) Disk Provisioning: Thin

c) Power on Automatically

8. Click “Next”

9. The next screen will show all values:

10. Click “Finish”
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6.3 Using Hyper-V

Before to start: You will receive the CSC disk (.vhdx) on zip format. Please unzip it and place it on 
your Virtual Machine directory before to start this wizard. 

1. Go to Hyper-V and Click → Action → New

2. Click Next > and Specify Name and Storage

3. Click Next > Select “Generation 1” 
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4. Click Next > Assign Memory: 4096 MB

5. Click Next > Configure Networking 

IMPORTANT: This is the EXTERNAL interface of the CSC. We are going to add the Internal 
Interface later.

6. Click Next > Connect Virtual Hard Disk  

Select the unzipped disk on “Use an existing virtual disk”
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7. Click Next > Summary > Finish . 

The machine will be created but we need to add the INTERNAL Interface.

8. Right Click the machine created > Settings > Add Hardware > Network Adapter

9. Click Add > and connect it to your INTERNAL virtual switch

10. Click Apply and OK 
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7 Powering up the CSC GRE
1. Power on the Virtual Machine 

2. SSH to the CSC using : ssh cscadmin@<First Internal IP> for the GRE Single. On the CSC 
GRE Cluster you need to SSH the 4th (csc-gre-a) and 5th (csc-gre-b) internal IPs respectively.

When prompted, put the following username and password to login on the CSC Console:

Username: cscadmin

Password: maidenheadbridge

Note: SSH to the EXTERNAL interface IP is not allowed. 
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3. Select 1) Show Configuration and Status check “Tunnel Status”
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4. Congratulations! You are connected to Zscaler.

5. Now, you can forward your traffic through the CSC using the following methods:

◦ Zapp in Tunnel and Local Proxy (recommended)

◦ PAC files: Traffic to Zscaler via VIP Proxy, Traffic direct to internet via Bypass Proxy

◦ Explicit proxy: via VIP Proxy.

◦ All port and protocols: If you are using Zscaler Cloud Firewall, you can use the Internal 
Cluster IP as your default Gateway to Zscaler and to send all ports and protocols. 

Take a look of next section for more details. 
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8 How to Redirect traffic to the CSC
The objective of the Cloud Security Connectors of Maidenhead Bridge is to provide a simple 
architecture, 100% proven that works,  to connect to Zscaler.

Every member of the CSC family follows the principle of “three IPs” on the internal side:

• CSC GW IP: To be used as Default Gateway for internal devices behind the CSC 
redirecting all ports and protocols to Zscaler when using Cloud Firewall.

• VIP Proxy (*):  This Virtual IP Proxy translates the packets directly to the Zscaler proxy. 
To be used when Zapp / PAC files are implemented or explicit proxy.

• Bypass Proxy(**): The Bypass Proxy enables a simple way to do Direct Bypasses to 
Internet. 

Here an illustration about this:

(*) Alternatively you can use Zscaler Global Proxies to send the traffic to Zscaler using port 
80/9400

(**) Alternatively you can use Zscaler Global Proxies to send the traffic to Internet using port 3128

You can download a PAC file Example from here: Click here

8.1 Obtain your traffic redirection IPs
The “Show Configuration and Status” menu provides the information of Traffic redirection options. 

Please, contact us at http://support.maidenheadbridge.com and we will provide the best method to your situation. 
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8.2 Verifying that your reaching Zscaler properly

8.2.1 Using a PC

Go to the following page: ip.zscaler.com from your PC

This page shows:

(values of this example between brackets [])

• Cloud name: [Zscaler Three] 

• Node: [London III]

• Zscaler internal values [165.225.16.84, 165.225.16.36,  zs3-lon3-1f2-sme]

• Your Gateway IP addresses [82.68.6.73. This is your public IP]
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• The name or logo of your organization [Maidenhead Bridge]

• The Username (if Authentication was enabled on the location) [first1last1@maidenheadbridge.com]

8.2.2 Using the “Show Configuration and Status” menu

This menu also goes to http://ip.zscaler.com . 

8.3 Checking Connection Quality

8.3.1 Using a PC

On the page ip.zscaler.com, click on “Connection Quality” and “Start Test” 
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8.3.2 Using “Speed Test” menu

The CSC runs the Speedtest.net. This function is experimental due to we need to rely on third party 
tools.
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9 CSC GRE – Admin Console
The CSC GRE has an Admin Console that allows to do different tasks. When you access to the 
Admin Console, the following information appears on top:

And you can select the following tasks:

9.1 Monitoring Tasks:

9.1.1 Show Configuration and Status

1. Show Configuration and Status. This menu show all parameters configured on the CSC 
GRE and does several checks. 

In total, 22 parameters are showed and 16 checks are done. All in one shot. 

CSC – GRE – Admin Guide – 2.6 Page 27 of 70 Date 31/08/19



Maidenhead Bridge – Cloud Security Connectors

CSC – GRE – Admin Guide                                                                                      Page 28 of 70 Date 08/08/19



Maidenhead Bridge – Cloud Security Connector GRE 

Here the detail of the information provided. Test are marked in bold

9.1.1.1 GENERAL INFORMATION

Here is general information about the device.  

• Company Name
• Location
• CSC ID
• CSC Date
• Soft Version

9.1.1.2 INTERFACES INFORMATION

This menu shows the following according each model:

CSC GRE Single:

• External: 
◦ Tunnel IP (eth0): <IP/Mask>
◦ Bypass Proxy Egress: <IP>
◦ Network Gateway:  <IP> (Alive or Not reachable)

• Internal:
◦ CSC GW IP (eth1): <IP/Mask>
◦ Network Gateway: <IP> (Alive or Not reachable)

CSC GRE Cluster:

• External: 
◦ Tunnel IP: <IP>
◦ Bypass Proxy Egress: <IP>
◦ CSC IP (eth0): <IP/Mask>
◦ Network Gateway:  <IP> (Alive or Not reachable)

• Internal:
◦ CSC GW IP: <IP>
◦ CSC IP(eth1): <IP/Mask>
◦ Network Gateway: <IP> (Alive or Not reachable)
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9.1.1.3 TRAFFIC REDIRECTION Options

This menu shows the following:  

• To Zscaler: 
◦ VIP Proxy: <IP:Port> (80/9400)
◦ Route all traffic via CSC GW IP
◦ Zscaler Global Proxies (port 80/9400) via CSC GW IP

• Direct to Internet:
◦ Bypass Proxy: <IP:Port> (3128)
◦ Zscaler Global Proxies (port 3128) via CSC GW IP

9.1.1.4 DNS INFORMATION

This menu shows the following:  

• DNS Server (1) IP: <IP> (Alive or Not reachable)
• DNS Server (2) IP: <IP> (Alive or Not reachable)

9.1.1.5 ZSCALER INFORMATION

Here the values configuration values of the GRE Tunnel . (Cloud, Public IP, Primary Tunnel, 
Secondary Tunnel)

• Zscaler Cloud: <Cloud Name>
• GRE tunnels egress Public IP: <IP>
• Primary Tunnel: 

◦ ZEN Public IP: <IP>
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◦ Tunnel IPs (local/zen): <IP> / <IP>
• Secondary Tunnel: 

◦ ZEN Public IP: <IP>
◦ Tunnel IPs (local/zen): <IP> / <IP>

9.1.1.6 TUNNEL STATUS

This menu shows the status of : Layer 7 Keepalives, Tunnel Keepalives and Tunnel status. This 
values are particularly important to troubleshoot firewall rules (NAT and Allow Rules)

• Primary (/Secondary) Tunnel (reachability):

◦ Layer 7 Keepalive is: Alive or Not reachable (check port 80 from < CSC Ext IP > to 
<ZEN Node IP>)

◦ GRE ZEN Tunnel IP is: Alive or Not reachable (check GRE protocol 47 from <CSC 
Ext IP> to <ZEN Node IP> and/or if the Location was created on the Zscaler GUI)

• Tunnel Status: 

◦ Primary tunnel is active since: <date / time>

◦ In transition (when switching tunnels)

◦ No active tunnel since: <date / time>

◦  Secondary tunnel is active since: <date / time> 

▪ -> (Note 1: Primary tunnel is under test. After 10 minutes of stability of Primary 
ZEN, the CSC will return to it)

▪ -> (Note 2: If Secondary tunnel fails, the CSC will return to Primary tunnel instantly)

Important: When the CSC is using the Secondary tunnel, is checking the quality of the Primary all 
time. When the Primary is on good quality for more than 10 minutes, the CSC returns 
automatically to the Primary. 
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9.1.1.7 HTTP://IP.ZSCALER.COM PAGE STATUS

This test is what Zscaler support always recommends to do to validate that you are effectively using
Zscaler. The CSC is going to the page http://ip.zscaler.com and is retrieving the following 
information:

• The Cloud and Node that you are using when connected. If you are not connected this value 
is blank.

• Your Gateway IP (this is your public IP in use)

9.1.1.8 BYPASS PROXY – EGRESS INTERFACE STATUS

This test validates if the bypass proxy egress IP can reach the external page pac.<cloudname>.net 
This test helps to troubleshoot if the firewall rules for the egress interface are correct. 

Result when successful:

• Bypass Proxy Egress Interface <Bypass Egress IP> can reach test page 
(http://pac.<cloudname>.net)

Result when fails:

• Bypass Proxy Egress Interface cannot reach test page (http://pac.zscalerthree.net)

◦ Please, verify connectivity from <Bypass Proxy Egress IP> to Internet

9.1.1.9 CLUSTER STATUS (Only GRE Cluster)

This test shows what CSC is the Cluster Active or Cluster Stand by. 

• This CSC (CSC ID) is Cluster ACTIVE (or Stand By)

9.1.1.10 AWS SSM Agent

This section shows the Status of the AWS SSM Agent. It helps to identify the CSC managed 
instance on AWS, showing the instance ID and the region where the CSC was registered.

Values when AWS SSM Agent not registered
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Value when registered. 

• AWS SSM Agent is active (running) since <date / time>; <year/month/days> ago

• Registration values: {"ManagedInstanceID":"<mi-xxxx>","Region":"<AWS Region>"}

9.1.1.11 SYSLOG INFORMATION

This section shows the values of the Syslogs servers IPs and Port in use.

• SYSLOG Server (1) (/2): <IP> is “Alive” or “not reachable” or “is not configured” 

• SYSLOG TCP Port: <TCP port>
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9.1.2 Show Interfaces Traffic

2. Show Interfaces Traffic: This selection shows the traffic information on all interfaces.

IMPORTANT:
• Press “q” to quit
• Press “?” for help

9.1.3 Traceroute and Latency Test

This test is particular important to check your internet path to Zscaler nodes and the quality of your 
link.

This Test does a MTR (MyTraceRoute) Tests to the Primary ZEN, Secondary ZEN, Zscaler PAC 
files and if the tunnel is UP, it check the reverse path from your ZEN active to your public IP (you 
don’t need to open a ticket to Zscaler requesting this any more) 
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9.1.3.1 Traceroute and Latency Test with the tunnel “Not Active”

If the tunnel is active, the MTR test will run through the tunnel. In some cases, you may want to do 
this test direct from your Location without the tunnel.  In order to do this test, use the CSC that is 
“Cluster Stand By” (or block the Keepalives on CSC Single)

Here an example of the test:

➢ Testing Primary ZEN

➢ Testing Secondary ZEN
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➢ Testing Zscaler PAC file Servers

➢ Reverse Path Test

9.1.3.2 Traceroute and Latency Test with the tunnel “Active”

When the tunnel is active the test runs from inside the tunnel. This is particular useful to see path 
from the Zscaler Cloud and to see the Reverse Path from the active node to your Public IP.

First, Check that the tunnel is active from the “Show Configuration and Status” menu. 

And run the “Traceroute and Latency Test” after:

➢ Testing Primary ZEN

CSC – GRE – Admin Guide – 2.6 Page 36 of 70 Date 31/08/19



Maidenhead Bridge – Cloud Security Connector GRE 

➢ Testing Secondary ZEN

➢ Testing Zscaler PAC file Servers

➢ Reverse Path Test
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9.2 CSC Admin Tasks

5. AWS SSM Agent (Register or De-Register)

6. Change SSH Password: Allows to change the password of the CSC.

7. Change Timezone: In case if needed, you can select your Timezone here. 

9.2.1 AWS SSM Agent (Register / De-Register)

The CSC GRE can be integrated as “Managed Instance” with Amazon Cloud (AWS).  

Amazon AWS offers on the Free Tier Account (https://aws.amazon.com/free)  the capability to add 
up to 1000 managed instances. 

The steps required to add the CSC to AWS are two:

1. Create the Keys to register using “Hybrid Activation”. 

2. Register the CSC with the Keys

9.2.1.1 Create the Key using “Hybrid Activations”

1. Open your AWS console and go to: “AWS Systems Manager”
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2. Click “Hybrid Activations”. We recommend to put the name to identify the CSC on 
“Activation Description” and “Default Instance Name”. In this example is cgs00045

3. Click “Create activation” to generate the Keys. Please, also note the AWS Region
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9.2.1.2 Register the CSC on AWS

Using the Keys and Region from the Step before, register the CSC.  

1. From the CSC Admin Tasks Menu, select “5) AWS SSM Agent (Register or De-Register)”

2. Register using the Keys and region:

Done! You have the CSC integrated with AWS now with the instance-id “mi-xxxxxxxxx” (“mi-
0c10191c04e30c0ef” in this example). 

Go to AWS System Manager →  Managed Instances you will be able to see your CSC.
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9.2.1.3 Checking the status of the AWS SSM agent

The “Show Configuration and Status” Menu shows the status of the AWS SSM agent at the bottom.

IMPORTANT: Go to Appendix B to learn how to “Run Commands” from the AWS console to 
monitoring the CSC and Update Bypass Lists. 

9.2.2 Change SSH Password

From this menu, you can change the SSH Password of the Admin Console.

9.2.3 Change Timezone

You can change the Timezone from following this Menu:
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9.3 Bypass Proxy
The Bypass Proxy allows you to connect certain allowed Domains direct to Internet when using 
PAC files (or Zapp on Tunnel and Local Proxy). 

By default, all domains are blocked and you need to insert the domains that you want to allow to go 
direct.

Important about domains and wildcards. The CSC uses the same nomenclature than Zscaler, but the 
PAC files are different. Please note the following examples:

CSC PAC file

Www.example.com Www.example.com

.example.com *.example.com

Important!  Be careful not to create an “Open Proxy” setting something like “.com” that will 
allow to pass all domains ending on “.com”

9.3.1 View Current Bypass List

This commands shows the current domains and subdomains allows to go direct to Internet

9.3.2 Configure Bypass List

In order to configure the Bypass List you have two options:

9.3.2.1 1) Auto – Bypass PAC URL

This is the recommended method to use. You need to create a “Bypass PAC file” on your Zscaler 
console.  The CSC will read the “Bypass List” from the “Bypass PAC file”. 
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By default, the CSC has configured this PAC URL: 

http://pac.<yourcloudname>.net/<yourdomain>/cscbypass.pac 

* You can change this URL via console menu. You can use an internal URL if you want. 

The idea of the “Bypass PAC file” is to act a central repository of all bypasses required.  Moreover, 
if you are managing the CSCs using AWS, you can update all CSCs in your network doing one 
AWS Run Command.

Example of “Bypass PAC file” 

function FindProxyForURL(url, host) {
        var bypassproxy="PROXY 1.1.1.1:3128; PROXY 2.2.2.2:3128";
           
           //* CSC bypass*/
            if ((shExpMatch(host, "*.firstdomain.com")) ||
    (shExpMatch(host, "www.fulldomain.co.uk")) ||
    (shExpMatch(host, "*.anotherdomain.com")) ||
    (shExpMatch(host, "*.salesforce.com")) ||
    (shExpMatch(host, "*.lastdomain.com"))){
    return bypassproxy
    }
}

Important Note: It is mandatory to use this function and format. Feel free to add lines but don’t 
change the format. We recommend to start filling the first line and the last line. Use middle lines 
for copy/paste. 
Note: You can use the lines in bold to copy/paste in your production pac file. Please, pay attention 
to replace 1.1.1.1 and 2.2.2.2 for your real Bypass proxy addresses. 

Bypass Proxy on the Zscaler Console:
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For example, here is a production pac file with the bypasses added:

Important:  Proxy Bypass is reachable only on port TCP 3128

Configuration Steps:

1. Select 1) Auto – Bypass PAC URL, you are invited to change the Bypass PAC URL, here an
screenshoot:

2. From here you can:

(a) 1) Update Bypass List

▪ Select 1)

▪ Yes to Refresh Bypass List. The CSC will download and display the PAC file 
content. 

▪ Say “y” (yes) to apply the changes.

▪ Verify that “Bypass List updated successfully”  or correct errors. 
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Or

(b) 2) Change Bypass PAC URL

Using this Menu you can change the PAC URL and to refresh the bypass list.

IMPORTANT:  Go to Appendix B to learn how to Update Bypass List from AWS
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9.3.2.2 2) Manual

If you want to update manually your bypass list, follow this steps

1. Select Option 2)

2. Ingress “y”

3. Add / Delete / Modify your full domains and subdomains

4. Please, CTL+X and “Yes” (and after next prompt Enter) to Save

5. The modified Bypass List will be displayed. 
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6. Apply Changes (y) or discard (n). If “y” you will receive the following message:
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9.4 Log Information
This section shows the tunnel logs (UP/DOWN) and the Cluster changes on the CSC GRE Cluster.

It is possible to view the current month and the last 6 months logs.

9.4.1 SysLog Server information examples: 

CSC GRE Single

CSC GRE Cluster:
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9.5 Configuration Wizards
This section allows to:

9.5.1 Change GRE IPs, DNS, Cloudname, Syslog

If you want to change this parameters, go to Menu 12) and follow the Wizard.

Menu “12) Change GRE IPs, DNS servers, Cloudname, Syslog and more” will show the current 
values configured and will allow change all of them. 

Please, note that a reboot may be required after changing this values. 
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9.5.2 Switch Tunnels

In certain conditions, it is desired to switch Primary ↔ Secondary tunnel values. Using this Menu 
13) you will be able to do it on one step. 

Please, note that a reboot is required after this change. 

And after the reboot, you can check that the tunnel where switched 
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10 Checking full visibility of the transaction on the 
Zscaler GUI
The most important thing when doing tunnels to the Zscaler Cloud is to do not NAT the connections
to the cloud. This allows to see the internal IPs on the Zscaler logs. Having visibility of the internal 
IPs is a must for full Security and Control. 

10.1 Web Logs
Go to Analytics > Web Insights

Click Logs and Filter by Location [cas00016 in this example is the name of the Location]

Apply Filters:

As you can see, you have full visibility of the Client IP [172.19.0.140 in this case]
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More in detail:

10.2 Firewall Logs
Same than before, with the CSC you will have full visibility on Firewall Logs of your internal IPs.

Go to Analytics > Firewall Insights

Click Logs and Filter by Location [cas00016 in this example is the name of the Location]

Apply Filters
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More in detail:
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11 Troubleshooting 

11.1 If the tunnels are not connecting
The “Configuration and Status” menu is providing all information required and is doing all checks 
for you. Start doing this command to verify everything, from configuration to reachability of 
gateways, DNS and Zscaler nodes.

According our experience, the most common issues are related to this:

1. GRE NAT and firewall rules in general.  GRE is not TCP. GRE is a protocol (number 47).
In order to do NAT you will required to do a STATIC SOURCE NAT and to allow 
protocol 47 in both directions.  

2. Are Vmware interfaces are properly mapped? 

Please, note that the first interface is EXTERNAL and the second is INTERNAL.

In this example:

- Network adapter 1 (EXTERNAL interface) is mapped to Net-192-168-1-0.

- Network adapter 2 (INTERNAL interface) is mapped to Net-172-19-0-0.

3. Are the configuration values correct? Check all values again using “Configuration and 
Status” menu. 
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11.2 Proxy Bypass

11.2.1 How to check if the Proxy Bypass is active?

Open a browser, type the IP of your proxy bypass plus (:) proxy port 3128, here the format:

http://<your bypass proxy ip>:3128

For example: http://172.19.0.217:3128/

and you will received the following page:

Please, note that the CSC ID is showed in this notification. This helps administrators to identify the
CSC in case is needed.

11.2.2 If you added the bypass in the PAC but forgot to update the 
CSC

In the case the bypass Domain Host is in your production PAC file but not configured on the CSC, 
the user will received the following message:
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11.3 PAC file troubleshooting
Please, for all this test use “Google Chrome”

11.3.1 How to check what PAC file URL is applied? (Effective Proxy 
Settings)

1. Using Google Chrome, go to: chrome://net-export/

2. Start Logging to Disk. Select a destination file and “Stop Logging” 

3. Go to https://netlog-viewer.appspot.com, choose file and go to “proxy”

CSC – GRE – Admin Guide – 2.6 Page 56 of 70 Date 31/08/19

https://netlog-viewer.appspot.com/
chrome://net-export/


Maidenhead Bridge – Cloud Security Connector GRE 

11.3.2 How to Check if the Domain destination is using VIP Proxy or
Bypass Proxy?

Using Google Chrome, do the following steps:

1. Open Developer Tools (More Tools → Developer Tools or CTRL+SHIFT+I)

2. Type the URL you want to check, for example “www.google.com”

3. Select “Network” → “Headers” and click on the URL. See picture below:

Check “Remote Address”. In this case is using 172.19.0.153:80 that is the VIP Proxy IP of the CSC.
In this case, the traffic is going via the tunnels.

4. Now go to a URL that you want to check if is going direct to Internet via the Bypass Proxy. 
In this example, we will use “salesforce.com” 

In this case, “Remote Address” is 172.19.0.154:3128 that is the Bypass Proxy IP:Port (:3128) . All 
Skype traffic is going direct to Internet and not via the tunnels. 
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12 Maidenhead Bridge Contact Information
Website: www.maidenheadbridge.com

Sales enquiries: sales@maidenheadbridge.com

Support: http://support.maidenheadbridge.com 
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13 Appendix A – PAC File Example
Click here to obtain a PAC file example that will help to redirect traffic to Zscaler and to do Local 
Bypasses or Direct bypasses to Internet. 
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14 Appendix B – “Run Commands” from AWS to 
monitor the CSC
 When you have your CSC registered on AWS as “managed instance” you can execute the 
“Monitoring Tasks” and also to “Update Bypass List”. This is particular important if you have 
several CSC and you want to update all in one task.

14.1 Documents
To execute “Run Commands” you need to have “Documents”. “Documents” contains a series of 
commands to execute. For simplicity purposes, we provide the “Documents” required for the 
operations of the CSC. 

 To obtain the Documents required you can open a ticket to http://support.maidenheadbridge.com 
(indicating your AWS Account ID) or to create them manually Copying/Pasting the information that
follows.

14.1.1 Creating a Document

From AWS System Manager → Document → Create Document

Next steps are:

1. Put the Name of the Document

2. Copy/Paste the content

3. Click “Create document”
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Check the document created going to “Owned by me” 
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On the following section you will find all documents with Name and Content. Please, create all of 
them on your console. 

14.1.2 List of Documents

Please, create the “Documents” using this values:

Name MHB-CSC-ShowConfigurationAndStatus

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - Show Configuration and Status",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-mt4"
            ]
         }
      }
    ]
}

Name MHB-CSC-SpeedTest

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - Speed Test",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-mt7"
            ]
         }
      }
    ]
}
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Name MHB-CSC-TraceRouteAndLatencyTest

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - TraceRoute and Latency Test",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-mt6"
            ]
         }
      }
    ]
}

Name MHB-CSC-UpdateBypassList

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - Update Bypass List",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-bp-refresh-list"
            ]
         }
      }
    ]
}
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Name MHB-CSC-ShowLogCurrentMonth

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - Show Log Current Month",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-l-current-month"
            ]
         }
      }
    ]
}

Name MHB-CSC-ShowLogCurrentMonth-2500Characters

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC - Show Log Current Month - (last 2500 characters)",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-l-current-month-2500"
            ]
         }
      }
    ]
}
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Name MHB-CSC-ShowLogLastSixMonths

Content {
   "schemaVersion":"2.2",
   "description":"MHB - CSC – Show Log Last Six Months",
   "mainSteps":[
      {
         "action":"aws:runShellScript",
         "name":"Runscripts",
         "inputs":{
            "runCommand":[
               "/home/cscadmin/aws-l-last-6-months"
            ]
         }
      }
    ]
}

Name MHB-CSC-SwitchTunnels

Content {
  "schemaVersion": "2.2",
  "description": "MHB - CSC - Show Configuration and Status",
  "mainSteps": [
    {
      "action": "aws:runShellScript",
      "name": "Runscripts",
      "inputs": {
        "runCommand": [
          "/home/cscadmin/aws-tun-switch"
        ]
      }
    }
  ]
}
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14.2 Run Commands
After you created the Documents, you are ready to Run Commands on the CSC. 

You can see the results of the operation on the “Output” section or to store the results on a S3 
Buckets for further inspection.

Note: The “Output” Section allows only 2500 characters. The Traceroute and Latency Test uses 
more than 2500. We recommend to store this command on a S3 bucket directly.

1. To Run Commands go to: AWS Systems Manager → Run Command and Select the 
“Command Document”

2. Scroll Down and Select the Instance:
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3. Scroll more down and Select “Output Options”

Here you can send to the Output to the console (up to 2500 characters) or to an S3 bucket or other 
options.

4. Finally, Click “Run” 

5. Wait to complete (Success) 
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6. Click “Instance ID” and expand “Output”

7. Scroll down the “Output” to see the complete result of the command. 

CSC – GRE – Admin Guide – 2.6 Page 68 of 70 Date 31/08/19



Maidenhead Bridge – Cloud Security Connector GRE 

15 APPENDIX C: Release Notes

Version 2.6 comes with the following enhancements:

➢ NEW! Configuration Wizard. It is possible now to change via SSH Console the following 
parameters: GRE credentials, DNS servers, Cloudname and Syslog servers.   

➢ NEW! Switch tunnels. It is possible now to switch Primary / Secondary via SSH console.

➢ Change: The default template of the OVA file requires 2 x CPU, 4 GB RAM, 8 GB disk. 
This increase was done due to the intensive use of the Bypass Proxy functionality by our 
customers.  If you are sending most of the traffic to via tunnels, you can reduce it to 1 x 
CPU, 1 GB RAM.

Version 2.5 comes with the following enhancements:

➢ NEW! Zscaler Global Proxies accepted for Bypass Proxy (port :3128). Now, on the CSC, it 
is possible to use the Zscaler Global Proxies IPs (Ranges 185.46.212.88-93 and 
185.46.212.97-98) to redirect traffic to the CSC Bypass Proxy.  You need to point your 
bypass URLs to (example) : PROXY 185.46.212.88:3128 . This feature was requested by 
several customers in order to create a unique global pac file using the Zscaler Global 
Proxies.

➢ Some cosmetic menu changes. 

Version 2.3 comes with the following enhancements:

➢ Logs to Syslog server. On version 2.3 you can setup one or two Syslog servers where to 
send the information about Tunnel and Cluster.

➢ Menu Changes: Two new options added to see the last month logs or last 6 months. 

Version 2.2 comes with the following enhancements:

➢ DNS Resolver timeout reduced  to improve response of time of Bypass Proxy when Primary
DNS fails or is slow. 

➢ Cosmetic changes on "Show Configuration and Status" menu. 

Version 2.1 comes with the following enhancements:

➢ Watchdog application added.  This watchdog will prevent any potential deviation behaviour 
or memory leak of the process running on the CSCs.

➢ Bypass proxy allows tunnelling to non standard HTTPS ports. This was requested by several
customers using Cloud Services like SAP. 
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Version 2.0 comes with the following enhancements:

➢ New! Bypass Proxy functionality : The Bypass Proxy solves the problem when is required 
to send traffic direct to internet and not via Zscaler ZEN nodes.The most common case is 
when destination web site accepts only traffic coming from a specific public IP.Without the 
Bypass Proxy, customers where obligated to have an internal proxy or to configure several 
firewall rules and routes to the destinations required to be bypassed.The Bypass Proxy 
simplifies this task: using the Zscaler PAC files servers as repository of your bypasses and 
automating the task with AWS, you can easily get up to date all your bypasses in all CSC 
instances.The Bypass Proxy acts as Web Firewall. It only allows to reach domains hosts 
defined by the Administrator.

➢ Resilient Algorithm: When returning to the Primary ZEN, Resilient Algorithm checks if the 
Primary ZEN was stable for 10 minutes before to change nodes.

➢ Timers: Timers were adjusted to better support locations with long delays (more than 250 
ms) to the ZEN Nodes.

➢ Internal IPs: The CSC GRE Cluster is using now five consecutive IPs for the Internal side. 
The first one is the Internal Cluster IP, the second the VIP Proxy, the third is the Bypass 
proxy, the fourth is the interface of the csc-gre-a and the fifth the csc-gre-a.

➢ External IPs: The CSC GRE Cluster is using now fourth consecutive IPs for the External 
side. The first one is the External Cluster IP, the second the Egress Bypass, the third is the 
interface of the csc-gre-a and the fourth the csc-gre-a.

➢ New! Monitoring Tasks Menu:  Traceroute and Latency Test. This Test does a MTR 
(MyTraceRoute) test to Primary & Secondary ZEN and Google DNS. In addition to this, if 
the tunnel is UP, this test does a MTR test on Reverse from the Zscaler node active to your 
public IP. This test is similar than the one provided on the Zscaler Analyzer tool with the 
advantage that has the ability to analyse the reverse path as well.

➢ New! Monitoring Tasks Menu:  Speed Test (Experimental). This test uses a third party tool: 
speedtest.net . This test provides the Ping delay, Download and Upload Speed.

➢ New! "Configuration and Status" Menu. Using this menu, in one shot you will retrieve 32 
configuration parameters and will do 16 status checks.

➢ New! AWS Management. Now, you can manage the CSC Anywhere from AWS as 
"Managed Instance"
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